Results 1 to 10 of 10

Thread: [Release] R8 Upgrade Package Version 1.1.1

  1. #1
    Administrator MatLi's Avatar
    Join Date
    Hong Kong

    Attention [Release] R8 Upgrade Package Version 1.1.1

    Dear all.

    In preparation for the soon to be released NovaX 350 firmware version 1.5 and App version 1.5 you are required to have your stock transmitter updated to the lasted R8 firmware release 1.1.1 as well. We have made the R8 upgrade package available for download here:

    The version 1.1.1 adds a second telemetry page. Please take note that the newly added telemetry page will only display telemetry data as soon as you have upgraded your NovaX 350 to the new firmware version 1.5 due for release within the next couple of days.

    Important note:

    After applying the R8 upgrade package you MUST rebind your stock receiver and transmitter.

  2. #2
    will do in the morning, thanks

  3. #3
    Here's a tutorial guide on the install.

  4. #4
    done and done works great

  5. #5

  6. #6
    Hey s.miles, Thanks for posting the link here on the forums. Much appreciated. You can also find the video now on our YouTube channel as well:
    Last edited by jlcamp7; 01.08.2016 at 05:52.

  7. #7
    Hey Guys,

    There are 2 different releases of the R8 firmware available, one with an early morning time stamp and one with a later in the afternoon time stamp. One version allows for the change of com port 3 to a different setting and one will not allow for the change of com 3 to a different numerical value. My PC has com 3 being used and the UART USB cable id identified as com port 10. I have tried changing the com 3 to 10 and proceed with out being able to initiate the firmware download. Error com port not available or something similar appears. I even tried to rename comports on my PC and still error reported. A couple of hours spent without any success. I also tried to plug cable into the PC first then the R8 and vice versa, plus installed a USB driver upgrade download as suggested by a couple of users on RC Groups.

    I hope to get this upgrade soon so I can get battery warnings and other telemetry data points displayed.

    I have not initiated a support ticket as it is a probable "cockpit error" in something I am either doing or not doing. I have viewed both the youtube and Vimeo totorials.


  8. #8
    Hey Michael,

    So great to see you over here on the RC Logger forums.

    It's very likely that a driver still might be missing as it can get quite complicated with so many different versions of PC with different hardware out there. Through our discussions I know you are a very knowledgable individual so I'm sure you've already ensured this, but just something else to check is ensuring the cable is fully pressed into the back of the radio to ensure proper connection. Sometimes it can take a little extra push to get it fully inserted.

    What version of Windows are you running? I will also discuss with our internal team to see if they might have input of any others that have encountered the issue of getting the update to run.

    Also you can try downloading the v1.1.1 pack directly from the R8 page (under the downloads tab) and see if that makes a difference for you). Here's a direct link to the page:

    If there is still issue's we can maybe get it worked out when we chat together via phone later this week.

    Again welcome to the RC Logger community!


  9. #9

    I just got home from a road trip today and scoured your website, then found a USB UART driver update which I installed and then followed your Vimeo tutorial again. Proceeded to upgrade the firm ware with cable installed again as per video and again no luck. I get "error opening COM port" after changing the com port from 3 to 10 which is what is assigned the USB/UART after I installed the driver update.

    I must be doing something wrong or not doing someting that needs to be done. I am not yet frustrated just miffed at myself because I must not be following your video or missing something. I will be available tomorrow to work with you guys to address this upgrade obstacle that i am hitting. The quad itself was no problem to upgrade. Oh, I also found RC EYE Tweaker and assigned the com port to number 10 on that app also. I'll hit you with a PM tomorrow, but afternoon looks to be a good time for me.

  10. #10
    I suppose the problem is caused by the unusual COM port number 10. You might try to change it to another value. See and for more info.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts