Results 1 to 3 of 3

Thread: The model has a problem yet, I can't seem to get help... Please help

  1. #1

    Sad The model has a problem yet, I can't seem to get help... Please help

    I studied the xtreme for days before it arrived, watched every video. I felt as if I knew the quad, even before it arrived. I have a background and not a newbie, just new to the RC Logger Xtreme one. This is set up PPM mode and FRsky D4R-11 which I use all the time. A Taranis TX which I also use all the time.

    I set it up with no issues, everything operated ( the instructions, Videos, Owners manual all are just EXCELLENT) as I anticipated and as demonstrated/taught on-line. Well, my first hover in "beginner" mode and only 2 feet of altitude. The stick in it's highest position and a linear throttle curve, I checked everything I knew to check and it all seemed "right"! So, I put the quad into "Sport" mode. Now, it flew much better until about 30 seconds (or less) into a hover flight in my family room, all carpeted and padded.
    But then, there was a "Tick" (lack of a better word) to the left.. An instantaneous small glitch pulling the quad to the left for only an instant. It scared me a bit, though as I did not expect it. I went through setup several more times, checked all functions and light sequences and the quad seemed perfect, on my work bench. I flew the hover several more times in sport and expect modes and that small "Tick" to the left, was still predominant.

    Tonight I came home and repeated all test and setup of the Xtreme One. Everything seemed perfect but, that "glitch" was still there. At the third Hover, the quad flipped all by itself. I was in Sport mode and Aux 2 was in the middle state (position) for normal flight. All the LEDs are responding correctly. I realized that it was not a "glitch" or "tick" but, for an instantaneous micro second, the flight controller is telling the quad to do a partial flip and sometimes, a full flip.

    I am very sad. My newest toy is bad and I can't get help fast enough. I wrote the company and I called them but, they would not speak about the issue and said they would write within 5 days. 5 Days? 5 Days? Common guys, this is my toy. Help please??/ I made a work order (Not sure what they call it) a service ticket but, I guess it is going to be some time before they respond.

    It is truly not fair that I be forced to purchase and replace the flight controller but, it appears that might be my only immediate recourse.


    My name is Steve, I live in New Mexico. And, I love these things and love even more to build them and all FPV.

  2. #2
    Administrator MatLi's Avatar
    Join Date
    20.09.2012
    Location
    Hong Kong
    Posts
    1,017
    Dear Steve.

    Please refer to this post.

    Note: You have posted your message in the wrong forum section. This section is for "forum or website account" related issues. You should post to the "Xtreme" forum section instead. For that reason the "product experts" may not have noticed your two posts as they both went into the wrong section where our tech product support team usually does not pay any attention to. This is the correct section.
    -=-=-=-=-=-=-=-=-=-
    Cheers,
    MatLi (Chris)

  3. #3
    Hey ave1,

    We have also updated your ticket in the support system as well.

    Be assured we will work with you to get you up and flying ASAP.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •