Results 1 to 7 of 7

Thread: I think my FCB is toast

  1. #1

    I think my FCB is toast

    I think its finally gone. It has been acting up the last couple of times I tried to fly but it always worked. Now all it does is go into flashing orange for 10 seconds, navigation leds light up and then everything shuts down. I get very, very low reading of volts across the two outside terminals. I don't fly it much anymore so it sits a lot. All my batteries are all charged up. So is this the end of this FCB?

  2. #2
    Hey fmimages,

    Have you tried checking the voltage of your lipo's to ensure they aren't the cause? If the batteries have set for long periods and also had a fair amount of use they could very well be worn out and not holding the charge.

  3. #3
    I tried several batteries some new and some old. I will check my voltages just to be sure. I was thinking of disconnecting one motor at a time to see if it's a shorted motor. I don't really think that would tell anything as I had a short in another (another brand quad) copter motor connection and it ruined the FCB board.

  4. #4
    Hey fm,

    This unfortunately won't work as the unit requires all 4 motors to be hooked up. Trying to start up without all 4 motors connected will give you a flashing red LED which is an error for over current.

    When you say it shuts down are you meaning you can actually start the motors and then about 10 seconds later it shuts down? If so does it also give a flashing red notification on the top LED?

    If this is the sequence you are getting then this means the unit is getting an over current draw somewhere.

    This could be a motor or esc causing this. You can always rotate the motors by hand to see if any of them feel like they have more resistance than the others. Also carefully inspect all the motor wires to ensure that they are fully connected and that the set screws holding the motor wires in are fully tightened. One of these single wires not being well connected can cause the issue you are experiencing.

    Check these things and keep us updated to see if we can get you back up and flying on the current Xtreme/FCB.


  5. #5
    Hi, what I am saying is that hooking up the battery only gives me a couple of seconds of activity. The top led blinks orange then shuts off as the navigation lights light up then shut down in sync. I tested all the batteries and they are all up on voltage. This has been a progressive thing that has gotten progressively worse over time.

  6. #6
    It definitely unfortunately sounds like the board is losing power. I know you already mentioned checking voltage at the main power connection and the power seemed rather low. If you can't see any bad soldering connection it could certainly just be that the board is at the end of it's life due to a component wearing out.

    I know you've had the Xtreme for some time. May I ask how long you've had it and how much flight time you've gotten out of it?


  7. #7
    This is one of the early ones. I'm not a steady flyer though. I have replaced some components when they break but this is the first time to have problems with the FCB. I've had the two motor issue problem, losing control after doing flips and rolls and pretty much some of the problems listed in the RC Groups discussion. This is not the first time I've seen this current behavior but it would start up and go after shutting down after a few seconds. Now it won't start no matter how many times to plug it in.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts