Results 1 to 5 of 5

Thread: Novax doesn´t want start / only a beep

  1. #1

    Question Novax doesn´t want start / only a beep

    Hello to everyone,

    i have updated my novax 350 last weekend with the newest firmware (v3) and the firmware for the transmitter.

    For the update i have used the videotutorials.

    Everything was fine, but if i want start now the motors it makes only a beep from the copter.
    Nothing happen, i have tried now several time to calibrate the copter but everytime the same result --> only a beep.

    Can someone help me please. Would be nice

    Best regards Tobi

  2. #2
    I had rhe same problem, try to re bind the transmitter After Firmware Upgrade. After Binding everything worked fine!

  3. #3
    Hey Tobi,Thank you so very much for reaching out to us.

    Welcome to the RC Logger forums. We are glad to have you join our community. In regards to your issue, Casi beat me to it (Thanks Casi ). Anytime the R8 transmitter firmware is updated then it requires a rebind with your NovaX 350. You should have received a bind plug with your NovaX 350. It would either be found in the R8 transmitter box or in the accessories box.

    The binding procedure can be found in the User Manual for the R8 radio system:

    The procedure can be found in section 10 (also page 10):

    6. Plug the binding cable into the 3-pin header connector BIND (r5) on the »Receiver.
    7. Connect the PPM cable to the 3-pin header connector PPM (r3) on the »Receiver and
    the other end to the PPM_IN socket on the power board.
    8. Connect the flight battery and power cable on the »NovaX 350.
    9. The RED indicator light on the »Receiver starts to flash fast, indicating the binding
    10. Press and hold the binding key (14) on the »Transmitter and slide the power switch
    POWER (10) up to turn the »Transmitter on. The LC display (12) displays “RXBinding..”.
    11. Binding is complete when the indicator light (r2) on the »Receiver is solid.
    12. Disconnect the »Receiver from the power supply.
    13. Turn the »Transmitter off.
    14. Remove the binding cable from the »Receiver.
    15. Connect the »Receiver to the »NovaX 350's power supply.
    16. Turn the »Transmitter on.
    17. [If channels are assigned] If you have previously assigned channels, test the
    »NovaX 350's functions. If necessary, refer to the corresponding chapters in the
    »NovaX 350 operating instructions. If the »NovaX 350 does not function as expected
    repeat the binding procedure.

    Also here is a video excerpt of this process:

    Please let us know if this gets you up and running. If not please let us know ASAP and we will work to ensure you are back up and flying as quickly as possible.

    Jamie and the RC Logger Team

  4. #4
    Hey Casi and Jamie,
    thx for your help (very good support), binding is fine, i have it tried again and the red light on the receiver is continous red (no blinking).
    The calibration of the transmitter via app and manually works too.

    ... but the start of the motors doesn´t work, if I bring the left transmitterstick (mode 2) to "bottom-left" the motors doesn`t start, it makes only beeeeeep

    maybe i can make later a short video and show you this

    Big thx for your help

    Tobi from Braunschweig

  5. #5
    Have you at any point removed the receiver from the NovaX? the fact that you aren't receiving a red flashing from the receiver on the NovaX means that there is an issue happening with the receiver itself.

    Have you checked to ensure that the 2 cables plugged into the receiver are fully secured and also fully secured to the NovaX flight board as well (found underneath the canopy)?

    If so you can also try taking the 3 pin servo cable connector and unplugging from the receiver and turning it around and plugging back in to see if this works.

    We need to get the receiver flashing so we can ensure it is in bind mode.

    To do this the bind plug must be inserted to the receiver and then power supplied to the NovaX.

    Also please power on the NovaX 350 and your transmitter and check to see if you get the notification of the Rx connection.

    You can find this in this picture below:
    (click to enlarge)
    Click image for larger version. 

Name:	R8 Rx Notification.jpg 
Views:	44 
Size:	834.7 KB 
ID:	2372

    See if any of this is helpful to get you bound back to the receiver.

    Best regards,
    Jamie and the RC Logger Team


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts